As promised, the Dev Team has released the Ultrasn0w 1.2.1 update to support unlock on iOS 4.3.1. But you have to remember that Ultrasn0w 1.2.1 works only with older basebands. So, you should update to iOS 4.3.1 only using PwnageTool or Sn0wbreeze so that your baseband won’t be upgraded.

Here are the guides to do it :

Guide: How to Use Sn0wbreeze 2.5 (Just use Sn0wbreeze 2.5.1 instead of 2.5)

Guide: How to Use PwnageTool 4.3

Ultrasn0w 1.2.1

To install Ultrasn0w 1.2.1, go to Cydia, add the repo : repo666.ultrasn0w.com, search for Ultrasn0w 1.2.1 and then tap the install button.

Subscribe to Tips Needed for more updates on the topic and also for jailbreak and unlock guides!